No announcement yet.

V3.0 Product Upload Promblem

  • Filter
  • Time
  • Show
Clear All
new posts

  • V3.0 Product Upload Promblem

    Hello everyone,

    I am almost positive this has been covered before, but I could not find it.... Anyway, I am trying to upload a large product database (9,000+ items). I have deleted all of my old products so I am starting from scratch. I chose to "Insert Only" (actually I have tried several options, just the insert only the most), and recieve the following error message:
    Microsoft JET Database Engine error '80004005'

    The changes you requested to the table were not successful because they would create duplicate values in the index, primary key, or relationship. Change the data in the field or fields that contain duplicate data, remove the index, or redefine the index to permit duplicate entries and try again.

    /admin/includes/, line 51

    Any ideas how to fix this? - Your Total Choice for the Outdoors

  • #2
    Is it a .txt file you are trying to upload from?

    Sounds like its either a comma missing somewhere kinda of problem or that there are duplicate primary keys in there. If it is a primary keys thing, then your primary keys are either missing or has duplicates in it. All products would need one unique identifier (which can be 1,2,3,4,5 or a,b,c,d,e or simply labels of the product), and it seems you have duplicates of the identifier. Or you could be just missing the identifying key. Or you could be labeling the wrong column as the unique key.

    To debug, I would make a copy of the database, but keep it to only 10 or 20 items for easier debugging, so its easier to narrow it down to whether its the key thing.
    I believe I had the same problem before when I tried switch shopping carts and had to upload stuff, but can't remember exactly what I did. Plus this is v3 which I don't have, so could be software too.
    Last edited by widgets; 12-11-2008, 06:17 PM.


    • #3
      Thanks for the quick reply! I worked some more and here's what I found:

      1. My product descriptions are LONG and contain commas, so I thought that might be causing the problem since I am uploading a COMMA delimited file. When importing it into an excel file and using the text to columns wizard, it does funny things. This is due to the comma separators separating when I don't want them to. So, problem solved... Not really.

      2. I tried the same file (with the comma problems) in my V2.x store and it worked like a charm. I reduced the size of this test file as suggested. SO, if it is a comma problem, it exists in V3.0 only.

      3. I tried again to upload the small file that worked in my existing 2.x store and got the following message:
      Status: Reading file.
      Microsoft VBScript runtime error '800a0007'

      Out of memory

      /admin/import_products.asp, line 208

      So, there is some more stuff to trouble shoot with. Any ideas? - Your Total Choice for the Outdoors


      • #4
        Sounds like a v3 problem, better to put in a help ticket to 3dcart support.
        New database schema or naming maybe?


        • #5
          Jimmy figured it out. I was tyring to upload products for the first time and had downloaded the template, which included the product ID. They were all blank of course since 3dcart automatically assigns them. They were all blank, which is a duplicate....

          I removed that column and it works like a charm now!

          Now all i have to do is get Excel & my PC to appreciate the spreadsheet masterpiece I have created with macros and crazy forumulas to automatically figure out names, categories, category images, descriptions, etc.

          Next i have to make it automatically assign page names and meta tags... :D
 - Your Total Choice for the Outdoors